Problems upgrading my forum from 3.5 to 3.8.

Buliding digital bulletin boards and forums
KBleivik
Site Admin
Posts: 178
Joined: Tue Sep 29, 2009 6:25 pm
Location: Moss Norway
Contact:

Problems upgrading my forum from 3.5 to 3.8.

Postby KBleivik » Sat May 28, 2011 11:36 pm

Today may 29 2011 I finally decided to upgrade my forum from version 3.5 to 3.8, but I had some problems using the Update package, and I have deleted config.php and forgotten my database password, so I decided to keep the database, but delete the file system and do a full upgrade.

So
  1. In the cPanel at my hoster, I created a new user for the forum database and remebered the password.
  2. Used this http://www.phpbb.com/support/documents. ... ickinstall Quick install guide.
  3. Uploaded the files to the webserver. After point 6 in the Quick Installation Guide:

    Click the INSTALL tab, follow the steps and fill out all the requested information.


    I got this
    Tables with the specified prefix already exist

    error. I get that error, because I try to create new tables that already exist in the database. So after a search on the internet i found the solution. I created a new config.php file:

    Code: Select all

    <?php
    // phpBB 3.0.x auto-generated configuration file
    // Do not change anything in this file!
    $dbms = 'mysql';
    $dbhost = 'localhost';
    $dbport = '';
    $dbname = 'mydatabase name';
    $dbuser = 'newly created user';
    $dbpasswd = 'new password';
    $table_prefix = 'phpbb_';
    $acm_type = 'file';
    $load_extensions = '';

    @define('PHPBB_INSTALLED', true);
    // @define('DEBUG', true);
    // @define('DEBUG_EXTRA', true);
    ?>

  4. Uploaded the new config.php file to the web server.
  5. Pointed my browser to install/database_update.php
  6. Removed the install folder on the server as explained in the Guide.
  7. Changed the permission on config.php to 644 and finally
  8. Pointed my browser to the forum, logged in and everything was OK.

Conclusion:

If you have trouble with the upgrade and decide to do a new installation of the file system, don't try to create new data base tables if you intend to use your existing database with all the posts.

Return to “Bulletin board and forum software”

Who is online

Users browsing this forum: No registered users and 1 guest